Alertas de seguridad

Vulnerabilidad de ejecución remota de código de Apache Solr

 En Apache Solr, el DataImportHandler (DIH), un módulo opcional pero popular para extraer bases de datos y otras fuentes, tiene una característica en la que toda la configuración puede provenir del parámetro "dataConfig" de una solicitud (request). El modo de depuración de la pantalla de administración de DIH lo utiliza para permitir la depuración / desarrollo conveniente de una configuración DIH. Dado que una configuración DIH puede contener scripts, este parámetro es un riesgo de seguridad. Un atacante puede usar el parámetro “dataConfig” para construir una solicitud maliciosa para la ejecución remota de código.  A partir de la versión 8.2.0 de Solr, el uso de este parámetro requiere establecer la propiedad del sistema Java "enable.dih.dataConfigParam" en verdadero.

Vulnerabilidad en gitlab.com

Se presenta una vulnerabilidad de exposición de información en gitlab.com versiones <v12.3.2, <v12.2.6, and y <v12.1.10, cuando se utiliza el bloqueo de la funcionalidad de petición de fusión, es posible que un usuario no autenticado visualice los datos de la tubería principal de un proyecto público; inclusive aunque la visibilidad de la tubería esté restringida. Por lo tanto, la canalización principal de las solicitudes de fusión de bloqueo se puede filtrar a los usuarios sin acceso a la información del proyecto.

Vulnerabilidad de divulgación de información en Apple macOS

Esta vulnerabilidad permite a los atacantes remotos revelar información confidencial sobre las instalaciones afectadas de Apple macOS. Se requiere la interacción del usuario para aprovechar esta vulnerabilidad, ya que el objetivo debe visitar una página maliciosa o abrir un archivo malicioso.

Vulnerabilidad en Oracle JDeveloper y ADF

¿En qué consiste esta vulnerabilidad?

Vulnerabilidad en el producto Oracle JDeveloper y ADF de Oracle Fusion Middleware (componente: ADF Faces) fácilmente explotable, que permite que un atacante no autenticado con acceso a la red a través de HTTP comprometa Oracle JDeveloper y ADF. Esta vulnerabilidad permite a los atacantes remotos ejecutar código arbitrario en las instalaciones afectadas de Oracle ADF Faces. No se requiere autenticación para explotar esta vulnerabilidad. Las versiones compatibles que se ven afectadas son 11.1.1.9.0, 12.1.3.0.0 y 12.2.1.3.0.

Vulnerabilidad permite la sobrescritura arbitraria de archivos

¿En qué consiste esta vulnerabilidad?

Las versiones 10.0, 11.0 y 12.0 del Trend Micro Deep Security Agent son vulnerables a un ataque arbitrario de eliminación de archivos, lo que puede tener un impacto en la disponibilidad. Se requiere acceso local al sistema operativo. Tenga en cuenta que solo los agentes de Windows se ven afectados.

Ejecución remota de JavaScript a través de correo electrónico

¿En qué consiste esta vulnerabilidad?

El caso CVE 2019-9454 relaciona la vulnerabilidad del Kernel de Android, en el driver i2c, que permite la posibilidad de escribir fuera de los límites de memoria debido a una corrupción en la misma. Lo anterior podría permitir un escalamiento local si se tienen los privilegios de ejecución necesarios. En este escenario, la interacción del usuario no es necesaria.

Aunque es posible la modificación de algunos archivos de sistema o información, el atacante no tiene el control sobre lo que puede ser modificado y su capacidad es limitada.

Vulnerabilidad de desbordamiento de búfer en Adobe Acrobat y Reader

Acrobat Reader es una aplicación desarrollada por Adobe Systems, diseñada para visualizar, crear y modificar archivos con el formato Portable Document Format, más conocido como PDF. El uso del formato PDF es muy común para mostrar texto con un diseño visual ordenado.

Vulnerabilidad de validación incorrecta de entrada en Android

Android es un sistema operativo móvil desarrollado por Google, basado en Kernel de Linux y otro software de código abierto. Fue diseñado para dispositivos móviles con pantalla táctil, como teléfonos inteligentes, tabletas, relojes inteligentes (Wear OS), automóviles (Android Auto) y televisores (Android TV).

Vulnerabilidad de Omisión de Restablecimiento de Fábrica (FRP)

El caso CVE-2019-5220 relaciona la vulnerabilidad de omisión de protección de restablecimiento de fábrica (FRP) en varios teléfonos inteligentes.El sistema no verifica de manera exhaustiva el permiso y un atacante podría realizar una determinada operación en un determinado paso del asistente de configuración.

Escalación de privilegio de emparejamiento bluetooth

Reportado en el identificador de CVE-2019-2225 esta vulnerabilidad permite realizar las siguientes acciones a través del emparejamiento de dispositivos por medio de Bluetooth que pueden llegar a ser maliciosos, esto sin ningún tipo de confirmación por parte del usuario. Para desarrollar este tipo de accesos no es necesario que el usuario realice algún tipo de interacción para la explotación y escalación de privilegios.

Error de validación de entrada

Los teléfonos inteligentes Nova 5i pro y Nova 5 con versiones anteriores a 9.1.1.190 (C00E190R6P2) y versiones anteriores a 9.1.1.175 (C00E170R3P2) tienen una validación incorrecta de la vulnerabilidad de índice de matriz. El sistema no valida correctamente el valor de entrada antes de usarlo como índice de matriz cuando procesa cierta información de imagen. El atacante engaña al usuario para que instale una aplicación maliciosa, una explotación exitosa podría causar la ejecución de código malicioso.

Vulnerabilidad en Firefox de confusión de tipos

Los usuarios del navegador ya pueden actualizar su versión para parchear la última vulnerabilidad descubierta, clasificada bajo el código CVE-2019-11707. La vulnerabilidad permite realizar ejecución remota de código arbitrario en las máquinas afectadas por el fallo, lo que a su vez lleva a la toma de control de la máquina por parte del atacante.

Vulnerabilidad en instalaciones afectadas de Dell EMC

Esta vulnerabilidad permite a los atacantes remotos ejecutar código arbitrario en las instalaciones afectadas de Dell EMC Storage Monitoring and Reporting. No se requiere autenticación para explotar esta vulnerabilidad.

Múltiples vulnerabilidades en productos F5

Se han publicado múltiples vulnerabilidades en productos F5 que podrían permitir a un atacante configurar el proxy para interceptar el tráfico, denegar el servicio o acceder a los archivos de la cuenta root.

Vulnerabilidad en WhatsApp por ejecución de código remoto

El caso CVE-2019-11931 relaciona la vulnerabilidad que posee WhatsApp, descubierta por Facebook, donde revela la existencia de falencias en la aplicación que conduce a ataques de buffer overflow permitiendo la ejecución de código remoto en el software de mensajería.