Alertas de seguridad

Vulnerabilidad en Advantech WebAccess por código arbitrario

Esta vulnerabilidad permite a los atacantes remotos ejecutar código arbitrario en las instalaciones afectadas de Advantech WebAccess Node. No se requiere autenticación para explotar esta vulnerabilidad.

webaccess

La falla específica existe dentro de bwrunrpt.exe, a la que se accede a través de 0x2711 IOCTL en el proceso webvrpcs. El problema se debe a la falta de una validación adecuada de la longitud de los datos proporcionados por el usuario antes de copiarlos en un búfer basado en la pila de longitud fija. Un atacante puede aprovechar esta vulnerabilidad para ejecutar código en el contexto del Administrador.

 

Acciones recomendadas para mitigar vulnerabilidad en Advantech WebAccess

Advantech ha publicado una actualización para corregir esta vulnerabilidad. Más detalles se pueden encontrar en: https://www.us-cert.gov/ics/advisories/icsa-19-260-01